Reply
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • [email protected]
    Participant

    Updating shortcoder to latest version changed the names of the shortcode. Screenshot below.
    This made the shortcode not show it’s desired result on the desired pages.

    There are over 200 pages with shortcoder on my site and the shortcode title was changed on 150+ of them.
    There was an extra 2 or 3 added at the end of the shortcode title.

    I can revert the site back, but really like to get it resolved so that I can use the new version.

    https://trello-attachments.s3.amazonaws.com/5ad957c3a2caf07634850224/5e22f814dcde9346de9c358d/56cd14031aebaaf2699016197b941593/image.png

    Hi Rohit,

    I guess there are duplicates shortcodes added during upgrade. This is not expected. But I guess it happened somehow.

    By this I mean, you would see two “infrared heaters” one with and without -2

    So the one without -2 should work as normal.

    You can confirm this. So the shortcodes wherever it is used won’t have any problem. You can delete the duplicates manually by selecting them.

    Can you please confirm the same ?

    Thanks,
    Aakash

    [email protected]
    Participant

    Not able to post

    [email protected]
    Participant

    Aakash,

    There are no duplicates. The version that has no -2 does NOT exist at all.

    Screenshot below. If I search for the shortcode name, there is only one occurence and it has -2.

    In summary, the old shortcodes converted to -2 and -3 versions and old ones are deleted causing the pages to not show the output.

    When I manually try to remove -2, it reverts back to the same version WITH -2. I can send a screecast if you want to see this.

    Screenshot:
    https://trello-attachments.s3.amazonaws.com/5ad957c3a2caf07634850224/5e22f814dcde9346de9c358d/e522901ffc57c4f0f7e64dba962601fd/image.png

    That name is verified by WordPress for duplicates before a shortcode is created. If that is automatically adding -2 that means there is another shortcode having the same name/slug. Otherwise there is no reason for automatic rename.

    Couple of things I can think of:

    – Shortcoder displays 500 shortcodes in one page. May be there are shortcodes in other pages with the same name.
    – There are shortcodes which are in drafts/not published state with same name.

    If you are ok, you can create a temprorary admin account and send me the login details to my contact form. I can login and check the issue for you.

    Contact

    Thanks,
    Aakash

    One more thing. I guess you deleted posts/shortcodes directly from the database right for some other issue ?

    If that is the case then I guess there are some left overs/traces of old posts in wp_posts table. May be in terms of post revisions etc.

    If you could run some queries in the table again remove any traces of the old posts.
    That way wordpress won’t rename.

    Hi Rohit,

    Could you please update on this ?

    Thanks,
    Aakash

    [email protected]
    Participant

    Aakash,

    I’m sure we don’t have a different page with a shortocder without -2. I checked.

    Also, we had to revert the whole site back by a day to restore the old shortcodes. So I’m not sure if creating admin account is worth it.

    This is not the site I considered changing the shortcodes from back end. So it’s not relevant here.

    In summmary, I’m sure that the shortcode itself changed to a -2 version with regular one not being there at all (since live pages that have the regular code didn’t show the code output at all).

    I’m hesitant to do the update again and I’m worried it will repeat.

    Please advise on how to proceed.

    Rohit,

    Did you consider my second reply ?

    One more thing. I guess you deleted posts/shortcodes directly from the database right for some other issue ?

    If that is the case then I guess there are some left overs/traces of old posts in wp_posts table. May be in terms of post revisions etc.

    If you could run some queries in the table again remove any traces of the old posts.
    That way wordpress won’t rename.

    Thanks,
    Aakash

    [email protected]
    Participant

    Aakash, Yes I did see your sencond message. This is not the site I tampered with from the database. It’s willysmoke.com. The site in question now is hvactraining101.com.

    Rohit,

    I can’t think of any other reason as no other users have reported such issue. Also I’m not able to reproduce the issue in all my test setups.

    Since you have moved to 4.6, shortcodes should be working for you now.

    Anyways for me to debug, could you please share below info ?

    – Is this happening in all your websites ?
    – List of plugins installed on the problematic site.
    – Export the shortcodes in v4.6 (using the “export” shortcodes button in the tool bar) and share the downloaded file with me via email aakash [dot] 19493 @gmail.com

    Thanks,
    Aakash

    [email protected]
    Participant

    Aakash,

    Since we moved back to 4.6 it’s working fine, correct.

    It’s only happening on this particular site hvactraining101.com.
    We upgraded 1 other site and it’s working fine there.
    List of plugins installed are: AAWP, Ad inserter, Akismet, All-in-One WP Migration, Calder Forms, Duplicate Page, Esyoh, LLC Client Plugin, Google Tag Manager for WordPress, GP Premium, HD Quiz, Infinite WP – Client, Interactive World Maps, Mailchimp Forms by Mail Munch, Post Type Switcher, Pretty Links, Really Simple SSL, Redirection, Shortcoder, ShortPixel Image Optimizer, Smush Pro, SOGO Add Script Header Footer, Tablepress, Thrive Architect, Thrive Clever Widgets, Thrive Leads, Thrive Product Manager, Thrive Ultimatum, TinyMCE Advanced, Title and Nofollow For Links, User Profile Picture, User Role Editor, WordPress Popular Posts, WP All Export, WP AutoTerms, WP Crontrol, WP External Links, WP Mobile Detect, WPMU Dev Dashboard, Yoast SEO

    I sent you the export over email.

    [email protected]
    Participant

    Hi Aakash,

    Do you have any update on this issue? We would love to upgrade to 5.1 but can’t do it without fixing this issue. Please advice.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.