Viewing 7 posts - 1 through 7 (of 7 total)
    • Author
      Posts
    • Schokokaese
      Guest

      I miss the function to change the parameter symbol. Because I want to use Shortcoder to embed tracks from soundcloud.com, but there are some „%“ in the code from the html 5 player:

      Code:


      For now it would be enough to change it hardcoded, e.g. to „*“. Or perhaps another save symbol – or maybe more than one, for example „**“. Unfortunately, my PHP skills aren’t good enough to change it by myself.

      Hello,

      I too heard that the “%” symbol is clashing with the content of the shortcode. Ill soon change it in the next version.

      Anonymous
      Guest

      Can you say (circa), how long this could take?

      Thank you 🙂

      Anonymous
      Guest

      Hi Schokokaese,

      Good day!

      Meanwhile, please see if doing an HTML entity works for you. “%” is “” and see if that works.

      Thanks!

      Anonymous
      Guest

      Hi raymond.

      Thank you very much for your suggestion. It works! With the correct entity % 😉

      Code:

       

      But by checking this I found a bug:

      When you click on the button from an existing shortcode to edit it, the plugin does not only load the existing code. Even in html view it decodes entities! This is not only relevant for users like me, who want to „trick“ the plugin to work with „%“ in the shortcode.

      No, as you can see above in the code (in my first posting you can see the original code), also the „&“ in the url are encoded („&“), because the url is a parameter from „http://w.soundcloud.com/player/?“.

      Therefore you cannot edit existing shortcodes easily. When you do not save the shortcode anywhere else, you have to search for it in the mysql database. Or even re-encode the shortcode.

      Anonymous
      Guest

      I see. Makes sense. Maybe you can try to place the URL on http://bit.ly/ and source it from there instead.

      This parameter symbol is now changed to %% instead of %.

      I think this is the permanent solution for this problem. This will avoid clashes with the native HTML codes.

      This is added in the Shortcoder v3.1 Just download/update to it.

      Download: http://www.aakashweb.com/wordpress-plugins/shortcoder/

    Viewing 7 posts - 1 through 7 (of 7 total)
    • The topic ‘Change parameter symbol?’ is closed to new replies.

    Subscribe for updates

    Get updates on the WordPress plugins, tips and tricks to enhance your WordPress experience. No spam.