Viewing 2 posts - 1 through 2 (of 2 total)
    • Author
      Posts
    •  airey74

      ok, as part of hardening wordpress sites a technique is to place the wordpress install into a sub-directory, leaving the index.php and htaccess files in the root directory. the admin area of wordpress allows you to add the settings for wordpress and the site URL as separate URLs.

      the problem with shortcoder is that after i made the initial 1st shortcode and then from the drop-down menu selected ‘2’ to create a new one the page’s internal loading looks to the wrong URL and takes me to a 404 error within the site.

      so i found the error and fixed it, at the footer of the file ‘shortcoder.php’ is the code:

      Code:


      and the updated section:

      Code:


      location.href = '< ?php echo get_option('home'); ?>/subdirectory/wp-admin/options-general.php?

      and it works now.

      the problem will happen when the plugin is updated and that fix i put in will be overwritten.

      srry if this is confusing to anyone, i've tried to write it in a way that communicated it well enough to help.

       Aakash Chakravarthy 
      Keymaster

      I think, this happens in wordpress versions 3.0 and above due t some change in the blog_info options. Ill fix it ASAP…

    Viewing 2 posts - 1 through 2 (of 2 total)
    • The topic ‘altered URL structure error + fix’ is closed to new replies.