Discussion forum for WP Socializer plugin

WP Socializer v2.0 - Beta 2 - Released

User avatar
vaakash
Site Admin
Posts: 733
Joined: 6 years ago
Location: India
Contact:

WP Socializer v2.0 - Beta 2 - Released

Postby vaakash » 5 years ago

Hello everyone,

I am glad to announce that the 2nd Beta version of WP Socializer v2.0 is released.
The WP Socializer v2.0 Beta 1 had mixed responses and some minor bugs.
In Beta 2, all the bugs are cleared and some additional features added.

Changes are:
* Shortcode button in posts page bug fixed.
* Instapaper button now available in both 16px and 32px sizes.
* One click setup template refinements.
* Default values are changed.
* New fixed message bar.
* Upgrade from v1.0 to v2.0 settings migration added.

You can download the WP Socializer v2.0 Beta 2 using the link below:
Download

Please feel free to send/post your bugs and plugin reviews. It will be very helpful.
Thank you,
Aakash Chakravarthy.
User avatar
Sim Brothers
Posts: 1
Joined: 5 years ago

Re: WP Socializer v2.0 - Beta 2 - Released

Postby Sim Brothers » 5 years ago

Hello vaakash!

First of all, congratulations to your WP Socializer plugin! It's amazing!

I'm using your 2.0 Beta 2 in my blog (Wordpress 3.2.1) and it works very well, but I have a problem with your plugin when I edit a page. When I open a page to edit, the editor opens in the HTML mode. When I try to change it to the Visual Mode, the textbox still shows the HTML but with no toolbar and a error is showed at the IE toolbar. If I try to change to HTML mode and back to Visual mode, even the textbox disappears. I've tried and got the same problem on Firefox.

Here is the error showed on IE:
Image

When I disable the WP Socializer plugin, the error disappears and the page editor works OK.

Did anyone told you about this or anything similar to it?

Thanks!
User avatar
vaakash
Site Admin
Posts: 733
Joined: 6 years ago
Location: India
Contact:

Re: WP Socializer v2.0 - Beta 2 - Released

Postby vaakash » 5 years ago

Actually, i fixed this error in beta 2, but wondering how this bug appears again.
I got another fix for this, and ill post the debugged file soon ! thanks for the patience..
User avatar
dexterxx
Posts: 4
Joined: 5 years ago

Re: WP Socializer v2.0 - Beta 2 - Released

Postby dexterxx » 5 years ago

Little imho important xhtml markup fix:

In includes/wpsr-socialbuttons.php
Line: 215 and 220
Add at the end of img tag add '/' [slash]

215:

Code: Select all

               '<img src="' . $spriteMaskImage . '" alt="' . $finalName . '" style="width:' . $pixel . '; height:' . $pixel . '; background: transparent url(' . $spriteImage . ') no-repeat; background-position:' . $finalSprites . '; border:0;" >' .

To:

Code: Select all

               '<img src="' . $spriteMaskImage . '" alt="' . $finalName . '" style="width:' . $pixel . '; height:' . $pixel . '; background: transparent url(' . $spriteImage . ') no-repeat; background-position:' . $finalSprites . '; border:0;" />' .


220:

Code: Select all

               '<img src="' . $finalIcon . '" alt="' . $finalName . '" border="0" >' .

To

Code: Select all

               '<img src="' . $finalIcon . '" alt="' . $finalName . '" border="0" />' .


= ButtonCountOnPage less XHTML validation errors.
User avatar
vaakash
Site Admin
Posts: 733
Joined: 6 years ago
Location: India
Contact:

Re: WP Socializer v2.0 - Beta 2 - Released

Postby vaakash » 5 years ago

dexterxx wrote:Little imho important xhtml markup fix:

In includes/wpsr-socialbuttons.php
Line: 215 and 220
Add at the end of img tag add '/' [slash]

215:

Code: Select all

               '<img src="' . $spriteMaskImage . '" alt="' . $finalName . '" style="width:' . $pixel . '; height:' . $pixel . '; background: transparent url(' . $spriteImage . ') no-repeat; background-position:' . $finalSprites . '; border:0;" >' .

To:

Code: Select all

               '<img src="' . $spriteMaskImage . '" alt="' . $finalName . '" style="width:' . $pixel . '; height:' . $pixel . '; background: transparent url(' . $spriteImage . ') no-repeat; background-position:' . $finalSprites . '; border:0;" />' .

Thanks for fixing the typo error. I didn't see that before. Thanks for the time !!!! :)
220:

Code: Select all

               '<img src="' . $finalIcon . '" alt="' . $finalName . '" border="0" >' .

To

Code: Select all

               '<img src="' . $finalIcon . '" alt="' . $finalName . '" border="0" />' .


= ButtonCountOnPage less XHTML validation errors.

Thanks for the fixing the typo error. This is now fixed. Thanks for your time !!!! :)