Discussion forum for WP Socializer plugin

jQuery errors with 2.4.7

User avatar
rgwhitaker
Posts: 5
Joined: 3 years ago

jQuery errors with 2.4.7

Postby rgwhitaker » 3 years ago

I have the latest version of WP Socializer (2.4.7).

When the WP Socializer is activated, I notice in Chrome in the Javacript Console the following errors:

WP Socializer float bar: There is a Javascript error in the page and the floatbar is hidden........wp-socializer-floating-bar-js.js:10
Uncaught ReferenceError: jQuery is not defined...........wp-socializer-floating-bar-js.js:14

This all started when I was getting some things cleared up with the developer of the commentluv plugin. He pointed out the errors to me with the following:

a lot of the errors look like they are related to you loading an old out of date or different version of the jquery library from the google api which does not have the .live functionality

you will need to disable any additions you have in your plugins/theme to not load from the google CDN or at least, load the latest version of jquery which has .live included (wordpress has the correct version which is normally loaded if you don't have a plugin to use the google api)

The issue seems to be with the WP Socializer plugin. Is there an update I need to download?

Thanks.
User avatar
vaakash
Site Admin
Posts: 733
Joined: 6 years ago
Location: India
Contact:

Re: jQuery errors with 2.4.7

Postby vaakash » 3 years ago

Can you please give your site URL ?? I'll check that out.
User avatar
rgwhitaker
Posts: 5
Joined: 3 years ago

Re: jQuery errors with 2.4.7

Postby rgwhitaker » 3 years ago

Yes. Thank you.

The blog portion of my website it http://www.boomerbazaar.com/blog/ .

Thank you for your assistance!
User avatar
vaakash
Site Admin
Posts: 733
Joined: 6 years ago
Location: India
Contact:

Re: jQuery errors with 2.4.7

Postby vaakash » 3 years ago

The error say that jquery is not loaded into the website.
WP Socializer has functions to load jquery into the theme.

The previous version v2.4.6 had some "jquery version usage error" it was then fixed in v2.4.7
So you don't need to do any editing work in the plugin.
Try using a version copy of the WP Socializer v2.4.7

Thank you.
User avatar
rgwhitaker
Posts: 5
Joined: 3 years ago

Re: jQuery errors with 2.4.7

Postby rgwhitaker » 3 years ago

How do I upgrade to 2.4.7?

When I go into WordPress, and then into the Plugins section, it says that I have version 2.4.6. (I thought I had 2.4.7, but I guess I don't.)

Is there a way that I can upgrade from within WordPress? I don't see anywhere where I can upgrade from within WordPress.
User avatar
vaakash
Site Admin
Posts: 733
Joined: 6 years ago
Location: India
Contact:

Re: jQuery errors with 2.4.7

Postby vaakash » 3 years ago

Go to the plugins section and in WP Socializer's row, you will see a notification. Use that to update.
Image
User avatar
rgwhitaker
Posts: 5
Joined: 3 years ago

Re: jQuery errors with 2.4.7

Postby rgwhitaker » 3 years ago

When I go to my plugins list and view the WP Socializer plugin, the update line is not there.

So, I thought that maybe I already have version 2.4.7, but if I click on the Settings link, the next screen shows that I have 2.4.6.

Is there another way to upgrade?

I tried downloading the 2.4.7 zip file, and then installing it that way through the WordPress plugins page, but I get an error.

Thanks for your help on this issue.
User avatar
rgwhitaker
Posts: 5
Joined: 3 years ago

Re: jQuery errors with 2.4.7

Postby rgwhitaker » 3 years ago

Something I just noticed:

I went into the list of plugins that I have and scrolled down to the WP Socializer plugin.

I then clicked on the Edit link.

The next screen showed me the php code for the plugin.

At the top, within the comments, it showed as version 2.4.7. So, I guess I have the latest version.

Should be okay now and not receive any jquery errors?

Thanks.